Q: When starting SuperMap iPortal service, what are the possible reasons and solutions for not passing the environment check?

A: SuperMap iPortal needs configuring JRE 1.8 or higher, and the license.

In the catalog of %SuperMap iPortal_HOME%\bin, you can check the version and configuration information of SuperMap iPortal by using “iportal.bat -v” ("./iportal.sh -v" for Linux/Unix). The possible reasons and solutions are:

(1) Use the right license and make sure the license is properly configured. Please refer to Configuring the License.

(2) The JRE/JDK version is too low or incompatible. Please download JRE/JDK1.8 or higher and set the environment variables.


20 Sept,2019
Tags: iPortal

More iPortal FAQ